GET /v1/get-screenshot/legacy

What is the /legacy API?

GetScreenshot is built on top of the latest versions of Puppeteer+Chromium. With the pass of time Puppeteer and Chromium have improved their performance resulting in a more reliable and consistent API.

However, due to changes in Puppeteer's recent versions, some of our old rendering strategies are not possible anymore.

We have been working hard in trying to keep the same rendering coverage as the previous version. Still, we ended up in a situation where we improved many pending rendering scenarios, but we also regressed in a couple.

We think this is unlikely to affect anyone since we are talking about just a couple of obscure rendering scenarios that seem to be specific to very particular website implementations. However, if it happens to be that the new API breaks your case (again, this is highly unlikely), we still want to give you the option to access the previous version. We are also hopeful that the folks at Google will fix some of the issues that caused the case regressions, so we don't have to rely on the legacy API anymore.

For how long would the /legacy API be available?

Again, we can't stress enough that it is unlikely that you will need to use this API at all. This API is built on top of NodeJS 8.X, and its availability it's contingent on our cloud provider supporting this runtime in the long run. We expect the API to be available for at least another full year (maybe more).

What methods are not available in the /legacy API?

The following methods are not available in the /legacy API:

  • click

  • strategy